Urban Terror Forums: Fix your lag in linux (Guide) - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
  • (3 Pages)
  • +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • This topic is locked

Fix your lag in linux (Guide) Rate Topic: -----

some fixes that might help

#1 User is offline   beast Icon

  • Account: beast
  • Joined: 28-February 10
  • Posts: 612

Posted 18 February 2010 - 10:17 PM

Many of us have been experiencing fps lag on linux that annoying slowness that makes the game jittery and such. I have an 8800GT card with the latest drivers and I get this problem when playing URT in my desktop environment. However for me, I was able to fix this lag and jumpiness using these steps. These MAY NOT SOLVE YOUR PROBLEM If you have a bad video card, this isn't going to make it "magically better."





1. To start off, make sure you have compiz disabled or uninstalled. This has been known to cause more problems.

2. If you are experiencing some jumpiness in your mouse movements, I have found this Urban Terror command helps:
r_finish 1


3. Make sure you are using minimalist graphic settings such as these:
seta cg_brassTime "0"
seta cg_marks "0"
seta cg_marktotaltime "0"
seta cg_maxFragments "0"
seta cg_novoicechats "1"
seta cg_sfxbrasstime "0"
seta cg_sfxParticles "0"
seta cg_sfxSurfaceImpacts "0"
seta cg_sfxVisibleItems "0"
seta cg_visibleBleeding "0"
seta com_blood "0"
seta com_maxfps "125"
seta r_detailtextures "0"
seta r_dlightBacks "0"
seta r_dynamiclight "0"
seta r_ext_compressed_textures "1"
seta r_inGameVideo "0"
seta r_lodbias "2"
seta r_picmip "2"
seta r_roundImagesDown "2"
seta r_stencilbits "0"
seta r_texturebits "16"


4. Command to start urt in a separate xsession
I located the idea from this on the Arch Linux Wiki. Many hardcore linux users might already know of this, but this is for the people that aren't aware of it.

This script (or command, however you use it) creates a new x session from which you can play your game. It runs your game outside your desktop environment and allows the game to run more smoothly in another "window"

sudo xinit /path/to/iourbanterror.i386 -- :1
or .x86_64

Bash script

#! /bin/bash
# runs iourbanterror in a seperate x session
read -p "This file will execute Urban Terror in a seperate x-session."
sudo xinit /path/to/iourbanterror.i386 -- :1


Once you have executed the game successfully in another xsession:
These keys will function as an "alt-tab"
[F7] to return to your desktop
[F9] to return to your game (once in the desktop)





Sticky please admins if this helps people :)

This post has been edited by beast: 18 February 2010 - 11:37 PM


#2 User is offline   kbar Icon

  • Account: kbar
  • Main tag: no|
  • Country:
  • Joined: 28-February 10
  • Posts: 239

Posted 18 February 2010 - 10:32 PM

ooh, maybe r_finish can help w/ my mouse accel.... or what seems like mouse accel

#3 User is offline   mitsubishi Icon

  • Account: mitsubishi
  • Country:
  • Joined: 28-February 10
  • Posts: 13,481

Posted 18 February 2010 - 10:41 PM

o come on, bringing a whole x server to run a game is a bit of an overkill; 1) people usually have the ram b) you have to have a buggy windows manager and application that get cpu time while playing.

i'd first use 'top' and see if anything gets cpu time before trying any such extreme measures.

#4 User is offline   beast Icon

  • Account: beast
  • Joined: 28-February 10
  • Posts: 612

Posted 18 February 2010 - 11:05 PM

View Postmitsubishi, on 18 February 2010 - 10:41 PM, said:

o come on, bringing a whole x server to run a game is a bit of an overkill; 1) people usually have the ram b) you have to have a buggy windows manager and application that get cpu time while playing.

i'd first use 'top' and see if anything gets cpu time before trying any such extreme measures.

It's not "overkill" if it solves the problem.

I have: 8800gt, AMD X2 64 at 2.6ghz and 6gbs of ram. I don't think it's the ram. Besides, most people use gnome and ubuntu which is where the problem usually is. Gnome is a lagger.

Not everyone uses slack, arch, flux, openbox, or those other minimum load Distros/WMs

This post has been edited by beast: 18 February 2010 - 11:10 PM


#5 User is offline   mitsubishi Icon

  • Account: mitsubishi
  • Country:
  • Joined: 28-February 10
  • Posts: 13,481

Posted 18 February 2010 - 11:10 PM

this is not a general solution; if had a severe fps drop you hit a bug; you don't 'solve' it with stopping everything but with finding a problem; with 6gbs you can run 100 urts and cpu is not an issue ever since it's supposed to be idle if you don't use an app even if it's open (that doesn't actively run jobs).

i heard compiz and stuff related to such 3d managers are usually buggy lately.

#6 User is offline   beast Icon

  • Account: beast
  • Joined: 28-February 10
  • Posts: 612

Posted 18 February 2010 - 11:30 PM

View Postmitsubishi, on 18 February 2010 - 11:10 PM, said:

this is not a general solution; if had a severe fps drop you hit a bug; you don't 'solve' it with stopping everything but with finding a problem; with 6gbs you can run 100 urts and cpu is not an issue ever since it's supposed to be idle if you don't use an app even if it's open (that doesn't actively run jobs).

i heard compiz and stuff related to such 3d managers are usually buggy lately.

I have compiz uninstalled. And no, I am not experiencing sever fps drops. Things like that normally do not get "magically fixed," however, I was experiencing minor drops with glitchy graphics. Using the seperate xsession helped eliminate the bugginess and allow me to get a solid 125.

#7 User is offline   angrydragon Icon

Posted 08 April 2010 - 04:25 AM

I have been experiencing lag but I think it's network related.
See the pic.
Posted Image

Any ideas?
Is there an FAQ on networking issues... I have googled but couldn't find anyfing

This post has been edited by angrydragon: 08 April 2010 - 04:26 AM


#8 User is offline   ObScUrE Icon

  •   head moderator   
    Co-Chief Community Moderator
  • Account: obscure
  • Country:
  • Joined: 28-February 10
  • Posts: 2,192

Posted 08 April 2010 - 04:49 AM

here from mitsu
networking guide

you should put this back in your signature. :wink:


//compiz and pulse audio driver are known for problems with UrT

Quote

BenQ-XL2420T|Filco-Ninja-TKL-MXRed|Logitech-G403|AKG-K70201000010 01101100 01110101 01110100 01010010 01100001 01110101 00100100 01100011 01101000~The quieter you become, the more you are able to hear.~

#9 User is offline   lebbra Icon

  • Account: lebbra
  • Main tag: bw|
  • Country:
  • Joined: 18-March 10
  • Posts: 170

Posted 12 April 2010 - 12:43 PM

I solved all my FPS drop problems simply with vertical sync ON.
FPS reduces to 60 but UrT runs really smoothly, and 60FPS are largely enough if there are no drops.
aka Dead f.S. - aka |CoN|-=V0l3ur=-, Playing UrT from 2001 - RedCap bot Developer

[img]http://www.dead.it/UrT/logop.png[/img]

#10 User is offline   mitsubishi Icon

  • Account: mitsubishi
  • Country:
  • Joined: 28-February 10
  • Posts: 13,481

Posted 12 April 2010 - 12:47 PM

well, but that's opposite of the point of the thread since vsync adds internal delays: visual delays (due to the forcing of lower FPS and vsync methods) and netoworking delays (a side effect of the lower FPS (especially since cl_maxpackets is locked in urt and it will lock at 30 on 60FPS)).

  • (3 Pages)
  • +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • This topic is locked

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942