Urban Terror Forums: mouseaccel + two commands, one button - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

mouseaccel + two commands, one button Rate Topic: -----

is it possible to add disablemacoxmouseaccel to an existing binding?

#1 User is offline   KarlMariaSeeberg Icon

Posted 12 September 2010 - 01:33 PM

hello …

since the old mousaccelthread came up again i started experimenting with my mousesettings, i usually play with mouseaccel on, so i turned it off and used all commands mentioned in the mouseaccel thread, playing offline against bots i instantly got better results but my ability to jump suffered from these new settings, it's like changing to a car without powersteering, thinking about my way of playing urt i noticed that i always push the walk button when aiming, seems to decrease snapping, so here is what i'd like to know: any chance i can bind "seta in_disablemacoxmouseaccel 1" to a button or even better is it possible to add "seta in_disablemacoxmouseaccel 1" to the binding on my "walk" key ? so two commands on one button?

solong

Karl

p.s. i started a new thread hoping i would get more response
if you don't like uptown, you are basically hating urban terror.

#2 User is offline   ObScUrE Icon

  •   head moderator   
    Co-Chief Community Moderator
  • Account: obscure
  • Country:
  • Joined: 28-February 10
  • Posts: 2,192

Posted 14 September 2010 - 12:07 PM

You can do it but I think it would better to get used to play without mouseaccel.

something to read:
http://forums.urbant...sxmouseaccel-1/

So here all you need:


set walkON  "+speed; in_disablemacosxmouseaccel 1"
set walkOFF "-speed; in_disablemacosxmouseaccel 0"

bind X      "+vstr walkON walkOFF"


Replace X with your actual walk key.



[Edit]
not sure if in_restart is required for it in case the above script fails try the following.


set walkON  "+speed; in_disablemacosxmouseaccel 1; in_restart"
set walkOFF "-speed; in_disablemacosxmouseaccel 0; in_restart"

bind X      "+vstr walkON walkOFF"


This post has been edited by ObScUrE: 14 September 2010 - 09:18 PM

Quote

BenQ-XL2420T|Filco-Ninja-TKL-MXRed|Logitech-G403|AKG-K70201000010 01101100 01110101 01110100 01010010 01100001 01110101 00100100 01100011 01101000~The quieter you become, the more you are able to hear.~

#3 User is offline   KarlMariaSeeberg Icon

Posted 15 September 2010 - 11:31 AM

hello again ..

many thanks for your help ...

how many commands can be added to one binding ? it would be great to be able to set mousesensitivity as well.

so long

Karl

I tried both of your suggestions, neither of those seem to work. i've added the three commandlines to my config and I've deleted my old walking bind, disablemacosxmouseaccel doesn't effect the new walking bind. Any idea what went wrong?

This post has been edited by KarlMariaSeeberg: 15 September 2010 - 11:51 AM

if you don't like uptown, you are basically hating urban terror.

#4 User is offline   ObScUrE Icon

  •   head moderator   
    Co-Chief Community Moderator
  • Account: obscure
  • Country:
  • Joined: 28-February 10
  • Posts: 2,192

Posted 15 September 2010 - 12:41 PM

Quote

how many commands can be added to one binding ? it would be great to be able to set mousesensitivity as well.

There is enough place to get all things done you need.

Here with mouse sensitivity:

set walkON  "+speed; in_disablemacosxmouseaccel 1; sensitivity 7; in_restart"
set walkOFF "-speed; in_disablemacosxmouseaccel 0; sensitivity 5; in_restart"

bind X      "+vstr walkON walkOFF"


change the number behind sensitivity for your needs 5 is the default value.^


[Edit]
The command doesn't exist in my client version, there is no auto-completion for it but eventual it's only in the mac executable file included so in case the problem is in my script try the following.

With waiting time.

set walkON  "+speed; in_disablemacosxmouseaccel 1; sensitivity 7; wait 5; in_restart"
set walkOFF "-speed; in_disablemacosxmouseaccel 0; sensitivity 5; wait 5; in_restart"

bind X      "+vstr walkON walkOFF"


you can try to make the wait time longer.

This post has been edited by ObScUrE: 15 September 2010 - 12:54 PM

Quote

BenQ-XL2420T|Filco-Ninja-TKL-MXRed|Logitech-G403|AKG-K70201000010 01101100 01110101 01110100 01010010 01100001 01110101 00100100 01100011 01101000~The quieter you become, the more you are able to hear.~

#5 User is offline   KarlMariaSeeberg Icon

Posted 15 September 2010 - 02:27 PM

hello ..

thanks again, works fine ... these settings did it:

bind < "+vstr walkON walkOFF"
seta walkOFF "-speed; in_disablemacosxmouseaccel 0; sensitivity 2,4; in_restart"
seta walkON "+speed; in_disablemacosxmouseaccel 1; sensitivity 2,4; in_restart"
seta sensitivity "2,4"

so long

Karl
if you don't like uptown, you are basically hating urban terror.

bullet_loaderAdvertisement
Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942