Urban Terror Forums: FPS drops/stutters - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • This topic is locked

FPS drops/stutters Rate Topic: -----

#1 User is offline   xernicus Icon

  • Account: xernicus
  • Joined: 15-February 12
  • Posts: 1

Posted 25 April 2013 - 11:31 AM

I feel awful that my first post on the forums is to beg for help about a problem.
Anyways, I'm having this interesting issue where my FPS will be as high as 95-120, and then it'll just drop like a rock. Even when there's nobody around. And it's not caused by grenades or smoke. Often when I get into firefights it will drop down to 20fps, and of course when I respawn (from dying because my FPS count is so low) I'll be back up at around 100fps again.

Probably my most frequented server is LA unlimited Algiers, so nobody else seems to be having the issue. I also have a (rather) steady ping of about 60ms, as I live on the West coast. :)

Here are my specs:
CPU: AMD Athlon II x4 620 (2.6 ghz Quad-core)
RAM: 8 GB DDR2, non ECC
GPU: AMD Radeon HD 6570 (2gb DDR3)
HDD: 3TB Seagate Barracuda 7200RPM through a SATA II interface (and no, it is surprisingly not failing yet).

I honestly can't remember if I've played UrT since I got my new graphics card, but I know that using my old POS 4550, the framerates never dropped like they do now. Perhaps I'm just using too new of hardware now? :P

Anyways, I'm looking forward to any suggestions that you all might have. I'm downloading the 4.2 update as I type this.

A few things that I haven't tried yet (that I probably should):
Changing CPU affinity (update: steadied the fps rate at 20ish. Meh.)
Adding UrT to custom 3d application settings list using VISION control panel (update: didn't help :( )

Anyways, thanks again! :biggrin:
~Xern


#3 User is offline   H0i Icon

  •   former FS member   
    Modeler
  • Account: h0i
  • Country:
  • Joined: 30-January 10
  • Posts: 941

Posted 25 April 2013 - 02:13 PM

View Postv3nd3tta, on 25 April 2013 - 12:48 PM, said:

it seems as your cpu doesn't like the animations - just as you describe it.
do you have a chance to try it on a better cpu?


I have a similar CPU and no problems. IMO the problem is in the graphics card. AMD graphic card drivers are well known to have bad opengl support. You might get lucky by getting the latest version of graphics drivers, or getting a slightly older one. But I'm not an amd gpu user myself, so there's not too much advice I can give.

#4 User is offline   zup100 Icon

  • Account: zup100
  • Joined: 10-November 11
  • Posts: 30

Posted 25 April 2013 - 09:57 PM

View Postxernicus, on 25 April 2013 - 11:31 AM, said:

I feel awful that my first post on the forums is to beg for help about a problem.
Anyways, I'm having this interesting issue where my FPS will be as high as 95-120, and then it'll just drop like a rock. Even when there's nobody around. And it's not caused by grenades or smoke. Often when I get into firefights it will drop down to 20fps, and of course when I respawn (from dying because my FPS count is so low) I'll be back up at around 100fps again.

Probably my most frequented server is LA unlimited Algiers, so nobody else seems to be having the issue. I also have a (rather) steady ping of about 60ms, as I live on the West coast. :)

Here are my specs:
CPU: AMD Athlon II x4 620 (2.6 ghz Quad-core)
RAM: 8 GB DDR2, non ECC
GPU: AMD Radeon HD 6570 (2gb DDR3)
HDD: 3TB Seagate Barracuda 7200RPM through a SATA II interface (and no, it is surprisingly not failing yet).

I honestly can't remember if I've played UrT since I got my new graphics card, but I know that using my old POS 4550, the framerates never dropped like they do now. Perhaps I'm just using too new of hardware now? :P

Anyways, I'm looking forward to any suggestions that you all might have. I'm downloading the 4.2 update as I type this.

A few things that I haven't tried yet (that I probably should):
Changing CPU affinity (update: steadied the fps rate at 20ish. Meh.)
Adding UrT to custom 3d application settings list using VISION control panel (update: didn't help :( )

Anyways, thanks again! :biggrin:
~Xern


If you are talking about Urt 4.1 then, there is no problem on Radeon HD cards. I have linux Debian and drivers from repository (standard) so they are pretty old and everything works really really good!
My processor is Core 2 Duo 2GHz and I'm not experiencing any fps drops. The exception is Suburbs map and 32 players on server, but even then with full smokes and everything else I do not have less than 60 fps, so its playable anyway.
My card is old its Radeon HD 3470.

I've done some tests in the past and there is probably now way you can have too old card for Urt4.1. I've done tests and there is no real difference (maybe in map loading but its all) between old like Geforce 4Titanium and today's cards. The other way its the same. I've done tests with Pentium 4 processor (3GHz) and newer Radeon HD cards like HD 5500 on board and result is worse than on my Core 2 Duo processor, like 120 fps on my custom demo on this Pentium 4 processor and this Radeon HD 5500 card on board, comparring to my Core 2 Duo 2GHz and this Radeon HD 3470 card on borad I have 180 fps.

The funny thing is that I've done this tests only on linux, cause I do not see much sense to play on Windows machines. The reason is that, comparing performance on the same machine I have now in my custom test in timedemo 1 on Urt4.1 180 fps on linux and 141 fps on Windows! On other machines the result is similar, always worse performance on Windows!

If you have Core quad processor and using Windows then you'll probably have performance like me when I'm using Linux.

Funnier still is performance in 4.2 version of Urt. I've experience a huuuuuuuuuuge! fps drops on 4.2 version like you, even without anyone on map and standing for example on Turnpike map and looking through pillars and not moving. Its irrational this performance thing and developing the new version of Urt. I've even spoke with developers of Urban Terror and coders and offer them my test experience and they decline my offer. Its childish, I feel that there is no real passion in developing this new version of Urt. And even worse is fact that (I'm not complaining cause this is a fact) Urban Zone preferring officially now the BETA!!! version of Urt4.2!!! This is madness and no responsibility and no reason to do it if you have major bugs like fps drops!

Even with all this facts I'm downloading 4.2 version now because maybe I'm wrong and after 4 months with this funny little bugs fixed, maybe... There is, still maybe... A chance (a little but maybe...) to fix this MAJOR fps drops bug for people with pretty enough powerful processors to play smoothly and feel that there is good direction in developing this new version!

Happy testing!

#5 User is offline   thelionroars Icon

  •   verified user   
  • Account: thelionroars
  • Country:
  • Joined: 21-September 11
  • Posts: 851

Posted 25 April 2013 - 10:37 PM

View Postzup100, on 25 April 2013 - 09:57 PM, said:

My card is old its Radeon HD 3470.


The problems seems to be on the newer series of cards (5xxx and up). 3 and 4 series seem to be ok.

bullet_loaderAdvertisement

#6 User is offline   zup100 Icon

  • Account: zup100
  • Joined: 10-November 11
  • Posts: 30

Posted 25 April 2013 - 11:18 PM

View Postthelionroars, on 25 April 2013 - 10:37 PM, said:

The problems seems to be on the newer series of cards (5xxx and up). 3 and 4 series seem to be ok.


Seems too be?

Some tests please?

On Radeon HD 5570 there was no fps drops in Linux. Make some tests please and then tell people that you are sure and you have done tests!

I've done tests on Linux and Windows (the results are the same but slower performance on Windows) deliberately on this processor Pentium 3 3GHz cause its slow for Urt, so we can see if its GPU problem comparring two cards HD 5570 and Geforce 6600 and we will see if any good coming from better GPU card. The test shows that there is none difference on this platform between this two cards and result shows on my custom demo with timedemo 1 that there is 121 fps. On the newer processors the logic is the same, do it for yourself!

Go to some friend and clean his basement and find old card and put it to your PC. It doesn't matter (maybe in super high resolution) if you have newer or older GPU. The requirement for Urt is processor. The geometry in Urt is not so much high in details even for older cards. I do not know about Intel GPU cause there is no chance to play on any of this cards even in worst detail, so I do not see the reason to test its performance.

I'm speaking generally cause all this tests was done in 800x600 pixel resolution but even on 1024x768 the result was almost the same, not much difference in performance. From 180 fps I've had 177 fps in timedemo. There was a bug and still is for Radeon HD 3470 (maybe for other cards too) in Orbital in biosfere in Urt4.1 where are fps drops without anyone on map, for higher resolution than 800x600. Where there is fps drops without reason and without reason there is absolutely none difference between 640x480 resolution and 800x600. Pass the 800x600 barier and 16 bit colours and you'll have on Orbital_sl fps drops in biosfere. Why? I don't know...

#7 User is offline   thelionroars Icon

  •   verified user   
  • Account: thelionroars
  • Country:
  • Joined: 21-September 11
  • Posts: 851

Posted 25 April 2013 - 11:49 PM

@zup tests and reporting them are a great idea, but people aren't always going to have access to the hardware. I can tell you my GTX680 is not stuttering, but that's not really saying much is it? As it happens I still have my old card which is a 5770 and I can do some testing over the weekend, it will just involve an hour or so of stuffing around with the cards and drivers.

My observations were based on seeing the few posts that are around regarding FPS problems. As much as the onus is on people like me in the QA team to test things as much as we can, the best way by far to get any bugs fixed is to make a polite post and give the dev team as detailed information on the bug and your setup as possible.

#8 User is offline   xernicus Icon

  • Account: xernicus
  • Joined: 15-February 12
  • Posts: 1

Posted 26 April 2013 - 05:09 AM

View Postv3nd3tta, on 25 April 2013 - 12:48 PM, said:

it seems as your cpu doesn't like the animations - just as you describe it.do you have a chance to try it on a better cpu?


If people can play UrT on a Pentium 4 (which I have done in the past) then there is no reason that my CPU, being some 5+ years newer than a P4, should be under scrutiny.

Here's what my own testing has concluded: The resolution does not matter. Nor does the texture detail level, or the filtering style. 800x600 will drop from 100fps to 21fps just like 1600x900. Using Ubuntu and Fedora (I triple boot FL, Ubuntu, and Windows) the framerate was a steady 60-80fps. However, Linux does not like my wireless card (even with the proprietary drivers) and therefore it isn't feasible to play using Linux.

I downloaded and installed newer drivers, but no dice. I know for a fact that both of my older cards (NVidia GEForce 8400GS and ATi Radeon HD4550) do NOT have this issue, leading me to think H0i might be right about OpenGL. At the very least, I have quite bit of reading to do about it.

Thank you all for replying so quickly! :)

#9 User is offline   Markinho Icon

  •   mapper   
  • Account: markinho
  • Main tag: QA|
  • Country:
  • Joined: 27-December 10
  • Posts: 438

Posted 26 April 2013 - 01:02 PM

Just fyi, AMD released Catalyst 13.4 and 13.5 beta, supporting a dozen of OpenGL extensions, try them out and see if they help

#10 User is offline   zup100 Icon

  • Account: zup100
  • Joined: 10-November 11
  • Posts: 30

Posted 26 April 2013 - 03:32 PM

View Postxernicus, on 26 April 2013 - 05:09 AM, said:

Here's what my own testing has concluded: The resolution does not matter. Nor does the texture detail level, or the filtering style. 800x600 will drop from 100fps to 21fps just like 1600x900. Using Ubuntu and Fedora (I triple boot FL, Ubuntu, and Windows) the framerate was a steady 60-80fps. However, Linux does not like my wireless card (even with the proprietary drivers) and therefore it isn't feasible to play using Linux.


Yes it matters. Do some tests, ask your friends, do research, do not think that you are know everything, show some facts. Then this community will thrive. Please, I'm telling you this cause I like this community, but I see a lot of degradation and lot of confusing statements regarding performance issues.

Read my posts, please. Read my topics about performance, then you will know better. I've done tone of tests on laptops, on old PC's and on newer laptops as well, and I must say that I don't know now, just posting facts, cause there is less logic in Urt engine than in my girlfriend behavior. Do it! Go to Orbital_sl on biosfere and you will see what happens, maybe not on your PC but a lot of players, not having generally problems with fps drops has this problem on Orbital_sl in biosfere, no logic, no thinking involved, just facts. I don't know why that bugs exists but they are, simple!

Also I'm explaining a problem with performance on different systems (Linux systems). So if you are using something newer than Debian stable, beware! Today there is no quality even in Linux system developing, so beware and careful and check my topic about performance. Also do not do tests from Phoronix, I like guys a lot, but they have no logic with testing Urt4.1 64bits performance. Who is playing 64 bit Urt4.1 on Linux systems? I do not know anyone who does, but they are testing performance with 64bit Urt4.1 binary, funny but true. Performance issue with 64bit Urt4.1 binary is (maybe you are using it and from there experiencing confusion) MAJOR PROBLEM. I've done tests and they are showing me that first:

-On 32bit (Debian Squeeze) system and 32 bit binary of Urt4.1 and my custom demo in timedemo I have 182 fps

-On the same machine but on 64bit system (Debian Squeeze) and 32 bit binary in the same demo and the same PC I have 181 fps.

-On the same 64 bit system and PC on this very same demo in timedemo I have 90 fps!!!

So, who wants to play on buggy 64 bit binary of Urt 4.1 ???
Maybe you have problem cause you are using it, I don't know. Anyways, use 32 bit binary even on 64 bit system, always!

Now I will do simple tests on newest Urt 4.2 cause I finished downloading it. I will report if MAYBE (no hope but maybe... doubt is healthy in small doses) there is some improvement in engine.

Again MAYBE!

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • This topic is locked

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942