Urban Terror Forums: [UrT 3.7] client/server mismatch when replaying demo - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

[UrT 3.7] client/server mismatch when replaying demo Rate Topic: -----

#1 User is offline   don Icon

  • Account: don
  • Main tag: GlaD-
  • Joined: 28-February 10
  • Posts: 2,639

Posted 04 May 2013 - 11:00 PM

lots of text, but i like to provide all relevant info in one go.:)

so i have a demo of a GTV'd match from 3.7. If you don't know what GTV is and what happens during a GTV stream, you probably can't help. Anyway, if you know what GTV does, you know that the cameraman can disconnect GTV from a server, and everyone is dumped back to the GTV main screen. When this happens during the demo, I get the following error:
http://i.imgur.com/07eeqlP.png

Note the ordering of the client and server versions. It's saying the "server" is running baseq3-1. The demo is most certainly a 3.7 demo, and the first ~25 minutes play back without issue. The problem occurs after the teams switch servers, which of course necessitates the recreation of the GTV stream. This would result in a new map being loaded for the GTV clients--whatever the default map for the GTV main screen is. I am pretty sure this switch is causing the error, but I have no idea what to do about it. I know there is more to the demo, because I ran the demo dumping tool, and there is another ~50 minutes of game.
Obviously the person recording the demo had no problems. I'm pretty sure the demo worked at one time, but I actually don't have proof of this; perhaps the demo is and always was broken?


I've tried swapping out baseq3 packs to no avail. the demo dumper says that the server was running 1.32b, which means everything up until and including pak8.pk3. Obviously 1.32c should be no problem, but I tried without pak9 just to be sure.
I tried a completely fresh install of Q3 using a completely different copy of the pak files, just in case mine had some modifications. Used a fresh copy of the 1.32c installer to generate pak1-8 and quake3.exe. Downloaded a new copy of 3.7 installer. Same error message.


Right now I'm wondering if the demo EVER worked. I assume someone would have complained about it not working, but the first round is so freaking boring that it's plausible nobody ever made it to the map switch lol. I also wonder if I am doing something wrong with my 3.7 installation, but I installed it dozens of times back in the day without incident.



So my questions are:
1) Any suggestions of things to try?
2) Can anybody with a 3.x install actually play this demo through from start to finish?
http://www.mediafire...mhuowjn33fcwysb
I'd /timescale 100 it unless you want to watch a bunch of p****** camp for 25 minutes.. I'm assuming maps 2 and 3 are much more entertaining

I'm trying to post some old school demos up on youtube, and the fact the 2nd one I've tried to play is giving me issues is a bit concerning.
GlaD-don
Past teams:
Partners in Terror | The Dark | Team Terror | Noobs Gone Wild | Xor | Blight Gaming | Area 51 Gaming | Team Lzuruha | Besserman6 | Console | No Care Bears | Zing | Pro5 | American Idols | Team Canada | No Defiance | Unlimited Gaming
<3 to the people who built and sustained the North American competitive community over the years. xil, r, vex, icu, bos, .e, '`|v|~, iF, -x-, ill, un, xor, glad & all the rest. thanks for the games


Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942