Urban Terror Forums: Urban terror 4.2 not starting? - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Urban terror 4.2 not starting? Rate Topic: -----

#1 User is offline   blackleader06 Icon

Posted 07 October 2013 - 03:47 AM

Hello, sorry if I sound like a noob, but I have been trying to get Urt 4.2 to start on my Mac (10.6.8), but with no avail. I've been downloading the updates through the Updater, but the game still doesn't start. It's basically been like this for the last few months or so. When I try to start Urban Terror, the screen goes black, like if it's about to start, but then flashes back to my desktop and then back to black over and over again. I thought the updates would help, but I guess they haven't, but the updates have been downloading ok it seems. What should I do? Should I just try deleting everything and reinstalling UrT?

#2 User is offline   KarlMariaSeeberg Icon

Posted 07 October 2013 - 01:16 PM

hello,

you should have added your thread to the mac support section ..

- were you able to run any version of 4.2 on your mac or has it always been like you described in your comment?
- open your applications folder > open utilities > run "console", try to locate urt's logs .. should be somewhere in there, maybe there is some output that tells you what made osx quit urt
- are you running osx' software updates on a regular basis?

cheers

karl
if you don't like uptown, you are basically hating urban terror.

#3 User is offline   ObScUrE Icon

  •   head moderator   
    Co-Chief Community Moderator
  • Account: obscure
  • Country:
  • Joined: 28-February 10
  • Posts: 2,192

Posted 07 October 2013 - 04:28 PM

-> Thread moved to 'Macintosh Support'

Quote

BenQ-XL2420T|Filco-Ninja-TKL-MXRed|Logitech-G403|AKG-K70201000010 01101100 01110101 01110100 01010010 01100001 01110101 00100100 01100011 01101000~The quieter you become, the more you are able to hear.~

#4 User is offline   blackleader06 Icon

Posted 07 October 2013 - 11:35 PM

Thanks for putting it in the right section.

Karl, I was able to run the game when I had installed it. Then after a while of not playing 4.2, I tried to get back on and it did the whole black screen thing.

As for the console thing, I'm not too pro at deciphering what each thing means, but when I tried to run it, at some point, the logs read "couldn't exec q3config.cfg" and "couldn't exec autoexec.cfg". After a few lines it says "QKEY could not open qkey for write". A few lines after that there is a line that says "Initializing OpenGL display" followed by "...setting mode 4:800 600". After those two lines is where it gets weird. The next line reads "invalid code module", and the line after that says "SDL_SetVideoMode failed: Failed creating OpenGL pixel format". It repeats these two lines over and over again. It goes on, and then it looks like it is trying to initialize that OpenGL thing again followed by some more repetition of the same two lines, until I force quit the application. Not sure if that is what you are looking for, if not, just ask me more.

And as for the updates, I usually update my mac every time that the software update pops up to tell me if there is any more updates. Don't think I've skipped any, but there is always a chance I might of. I just ran some new updates today for the mac, but Urt 4.2 still does the same thing.

This post has been edited by blackleader06: 07 October 2013 - 11:37 PM


#5 User is offline   KarlMariaSeeberg Icon

Posted 08 October 2013 - 01:16 AM

well, i am far from a computer wizard myself but sometimes those logs actually give noobs like us a hunch...

where is urban terror located on your harddrive .. the application itself i mean?

can you go to macintosh harddrive/ user/ your username/ library/ application support/ quake3/ q3ut4/
you should find your q3config.cfg in that folder (i am on mountain lion here so i am not 100% sure that's the exact path, you can't use the search function here cause osx excludes system folders)
just change the name of q3config.cfg, urt can't find the file and will create a new one, after that try to run urt again ..

i am not sure the game crashed due to some error within the config file but we would be sure a clean q3config.cfg doesn't do the trick ..

This post has been edited by KarlMariaSeeberg: 08 October 2013 - 03:23 PM

if you don't like uptown, you are basically hating urban terror.

#6 User is offline   deltaalpha Icon

  • Account: deltaalpha
  • Joined: 06-August 12
  • Posts: 2

Posted 11 October 2013 - 10:47 PM

I have the same issue. Black screen flashes back and forth, never gets to the UrT menu nor plays the intro sound.

I am also on 10.6.8 - I had 4.2 working near when it was originally was released but only started trying to go away from 4.1 now so I downloaded the new updater and ran it with the above result after it had completed.

#7 User is offline   blackleader06 Icon

Posted 11 October 2013 - 11:07 PM

Karl, the pathway on my computer was wrong. The Quake3 file in the Application Support was for 4.1, so I moved the 4.2 files into the Application Support and renamed that file Quake3, and then renamed the original Quake3 (the 4.1 Quake3) something else so that the computer wouldn't get confused. Started it and ran fine, even found my favorite server. I don't know why I had that 4.2 folder somewhere else and named "Urban Terror 4.2". I think I had named that folder when I downloaded it and worked.

Delta, if your game still does that, try moving the 4.2 folder that you have, move it into the correct pathway that Karl posted, and make sure the 4.2 folder is called "Quake3". If your 4.1 files are also in a folder named "Quake3", I'd probably change that, though I don't know if 4.1 will work after that. Me, I just renamed that 4.1 "Quake3" folder in App Support "Quake312", and left it there, so that if I ever did want to play 4.1, I could possibly erase the 12 on the Quake three and maybe play it, though I doubt I'll be playing 4.1 since my favorite servers are moving to 4.2. Thanks for the help guys!!!

#8 User is offline   deltaalpha Icon

  • Account: deltaalpha
  • Joined: 06-August 12
  • Posts: 2

Posted 12 October 2013 - 12:30 AM

beautiful! works now.


the path where all of the pk3 files etc for others in the future:


/Users/MACUSERNAME/library/Application Support/Quake3/q3ut4

#9 User is offline   KarlMariaSeeberg Icon

Posted 12 October 2013 - 01:08 AM

hmm ...

good to hear you guys got urt 4.2 to work now... i am still wondering what happened there...

but it sounds like urt got confused by the prior version of urt you were running ...

if you run 4.1 and after that download and start urt 4.2 you got a mix up of both versions ..

what any urt application does if you start it (and the following is an assumption based on my own experience entirely) is go to the path i posted and read all the files found in q3ut4 or if some files are missing urt will create said files..(e.g. q3config.cfg) ..

so what you should do if you are a 4.1 user who wants to play 4.2 is to go to the application support/quake3 folder and simply rename it to quake3_4.1, after that you can conveniently start 4.2 and 4.2 will create its own version of a quake3 folder .. if you want to go back to playing 4.1 you rename quake3 to quake3_4.2 and rename quake3_4.1 to quake3 .. or you can do it like cyrus has suggested here

if you were a 4.1 user and didn't rename or move your quake3 folder prior to starting 4.2 for the first time you are probably running some sort of q3ut4 bastard folder consisting of "old" 4.1 files and newly added 4.2 files like authkey.cfg ... 4.2 then will be using your old 4.1 q3config.cfg and that's not ideal since you might have problems with certain maps or experience performance issues ..

in my opinion this can be considered a bug and might scare away potential 4.1 to 4.2 switchers on mac .. could be some mac complaints are only based on this mixup

it would be great if fs fixed this if they wanted 4.1 mac players to migrate to 4.2

----
btw. i don't know what 4.2 files you moved to that quake3 folder (you didn't have to do that) the copying of those files could cause errors .. if urt stops working just rename the quake3 folder and run the 4.2 application again ..

This post has been edited by KarlMariaSeeberg: 12 October 2013 - 01:13 AM

if you don't like uptown, you are basically hating urban terror.

#10 User is offline   thorbynow Icon

  • Account: thorbynow
  • Joined: 31-October 12
  • Posts: 6

Posted 03 December 2013 - 11:55 PM

View PostKarlMariaSeeberg, on 08 October 2013 - 01:16 AM, said:

well, i am far from a computer wizard myself but sometimes those logs actually give noobs like us a hunch...

where is urban terror located on your harddrive .. the application itself i mean?

can you go to macintosh harddrive/ user/ your username/ library/ application support/ quake3/ q3ut4/
you should find your q3config.cfg in that folder (i am on mountain lion here so i am not 100% sure that's the exact path, you can't use the search function here cause osx excludes system folders)
just change the name of q3config.cfg, urt can't find the file and will create a new one, after that try to run urt again ..

i am not sure the game crashed due to some error within the config file but we would be sure a clean q3config.cfg doesn't do the trick ..



I, about those folders, dont have any,... neither q3config.cfg file.. wierd.

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942