Urban Terror Forums: Jump mapping help wanted - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Jump mapping help wanted Rate Topic: -----

shaders

#1 User is offline   Extra1 Icon

  • Account: extra1
  • Country:
  • Joined: 22-February 15
  • Posts: 63

Posted 27 February 2015 - 09:10 AM

Hi,

I started mapping on my first jump style map and have made custom textured icy style tiles and some other custom textures
When i want to make those textures slick using a shader file the texture is not slick.

Am i doing something wrong because i have put some common slick ontop of my original brush?

ALso includes .map file

http://www.mediafire...2tz4/filter.pk3

LoooL i dont know if this noobfilter is any good is it to easy ????

#2 User is offline   AnonDafb Icon

  • Account: anondafb
  • Main tag: <
  • Country:
  • Joined: 04-September 14
  • Posts: 339

Posted 27 February 2015 - 02:08 PM

View PostExtra1, on 27 February 2015 - 09:10 AM, said:

Hi,

I started mapping on my first jump style map and have made custom textured icy style tiles and some other custom textures
When i want to make those textures slick using a shader file the texture is not slick.

Am i doing something wrong because i have put some common slick ontop of my original brush?

ALso includes .map file

http://www.mediafire...2tz4/filter.pk3

LoooL i dont know if this noobfilter is any good is it to easy ????

Ye, that jumps is easy x'D
I think you are using a bad script for make a icytexture!
I use this script for make a glass icy texture (I replace it with your textures and folders):

textures/spreeicy/icytexture
{
	surfaceparm nodamage
	surfaceparm slick
	qer_editorimage textures/spreeicy/noobfilter.jpg
	surfaceparm trans
	cull disable
	qer_trans 0.5

	{
		map textures/spreeicy/noobfilter.jpg
		blendfunc add
		//rgbGen vertex
		tcgen environment
		tcmod scale 4 4
	}
	
}

I clear your slick textures.
I replace your wood textures (You can put in a .shader for no damage).
I prefer use this script for no damage.

textures/yourfolder/yourtexture
{
qer_editorimage textures/yourfolder/yourtexture.jpg
surfaceparm nodamage
{
map textures/yourfolder/yourtexture.jpg
rgbGen identity
}
{
map $lightmap
rgbGen identity
blendFunc GL_DST_COLOR GL_ZERO
}
}


You can see here an example -> https://www.mediafir...2p21sznzthh4rec

This post has been edited by AnonDafb: 27 February 2015 - 03:12 PM


#3 User is offline   Extra1 Icon

  • Account: extra1
  • Country:
  • Joined: 22-February 15
  • Posts: 63

Posted 27 February 2015 - 06:20 PM

http://www.mediafire...n3/shot0002.jpg

my texture now gone i think maybe script bad?

#4 User is offline   AnonDafb Icon

  • Account: anondafb
  • Main tag: <
  • Country:
  • Joined: 04-September 14
  • Posts: 339

Posted 27 February 2015 - 06:25 PM

View PostExtra1, on 27 February 2015 - 06:20 PM, said:

http://www.mediafire...n3/shot0002.jpg

my texture now gone i think maybe script bad?

Idk, but that script that you had in the first "filter" map, don't work with me too.

#5 User is offline   Extra1 Icon

  • Account: extra1
  • Country:
  • Joined: 22-February 15
  • Posts: 63

Posted 27 February 2015 - 07:21 PM

http://www.mediafire...lter%282%29.pk3

i tried everything renaming paths renaming texture rezising texture nothing seems to work if anyone know's why and have solution pls share.

#6 User is offline   AnonDafb Icon

  • Account: anondafb
  • Main tag: <
  • Country:
  • Joined: 04-September 14
  • Posts: 339

Posted 27 February 2015 - 07:53 PM

View PostExtra1, on 27 February 2015 - 07:21 PM, said:

http://www.mediafire...lter%282%29.pk3

i tried everything renaming paths renaming texture rezising texture nothing seems to work if anyone know's why and have solution pls share.

Remember add your .SHADER in the "shaderlist.txt"...when you do this, the script than you add like the icy go to appear in the Textures for your map.

#7 User is offline   Extra1 Icon

  • Account: extra1
  • Country:
  • Joined: 22-February 15
  • Posts: 63

Posted 27 February 2015 - 08:08 PM

ok this helped thanks

#8 User is offline   AnonDafb Icon

  • Account: anondafb
  • Main tag: <
  • Country:
  • Joined: 04-September 14
  • Posts: 339

Posted 27 February 2015 - 08:16 PM

Okay! :D

#9 User is offline   Extra1 Icon

  • Account: extra1
  • Country:
  • Joined: 22-February 15
  • Posts: 63

Posted 28 February 2015 - 12:13 AM

Its getting frustrating now.

Had it working then i add more lines to my shaderfile for the other textures and i get a orange log in screen like i've comprimised shaders.

Reverted to putting common slick ontop.

Icy shasder:

textures/icyspree/noobfilterspree
{
qer_editorImage textures/icyspree/noobfilterspree.tga
surfaceparm nodamage
surfaceparm slick
{
map textures/icyspree/noobfilterspree.tga
}
{
map $lightmap
blendFunc filter
}

Slick shader:

textures/icyspree/noobfilterspree:q3map
{
surfaceparm slick
}
textures/icyspree/bluespree:q3map
{
surfaceparm slick
}
textures/icyspree/bluespree1:q3map
{
surfaceparm slick
}

When i use this urt becomes comprimised.

Here i made it using slick ontop but this is more work and perhaps slower compile.

I made the noobfilter slightly harder now need 1750 ups speed.

http://www.mediafire...i7oasgh/ooo.pk3

Posted Image

This post has been edited by Extra1: 28 February 2015 - 12:17 AM



  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942