Urban Terror Forums: Who register in masters servers list - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1

Who register in masters servers list Rate Topic: -----

#1 User is offline   pando855 Icon

  • Account: pando855
  • Joined: 15-November 13
  • Posts: 3

Posted 18 July 2017 - 10:58 AM

I have a server working perfectly. I can access from WAN and all it is configured correctly.

The problem is when it tries to register in masters. It seems it is registering random ports and nowadays it isn't in the master list.

Does someone know how this system works?

I'm running the server and spunky bot in two containers. My docker-compose is this:

version: '2'
services:
server:
image: tomdesinto/urbanterror:4.3.2
restart: unless-stopped
network_mode: bridge
ports:
- "27960:27960/udp"
volumes:
- ./q3ut4:/q3ut4
- ./maps:/map

bot:
image: pando85/docker-spunkybot
restart: unless-stopped
network_mode: bridge
links:
- server
volumes:
- ./q3ut4:/opt/urbanterror/.q3a/q3ut4/
- ./spunky-conf/conf/:/opt/spunkybot/conf/


#3 User is offline   Dirtycamacho Icon

  • Account: dirtycamacho
  • Country:
  • Joined: 19-March 20
  • Posts: 2

Posted 27 November 2020 - 04:56 AM

Hey, I know this is an old post and I'm not sure if this information is helpful at this point, but if your server is appearing in the master servers list under your IP address but using random ports and it's not appearing in the in-game server list, it's more than likely an issue with your network firewall. Most enterprise/higher-grade firewalls (and even some consumer-grade) do port translation on outbound traffic where it takes the data being sent out and randomizes the port that it uses to send the data. This is called Network Address Translation or NAT. NAT is typically applied to inbound traffic, but the issue you're experiencing is related to the outbound NAT on your firewall. The problem is that the master servers are receiving a 'hello' packet (of sort) from your IP address on a random port and since the master servers don't know you have outbound NAT turned on, they reply to your IP address using the port on which the 'hello' packet was received. That communication is then blocked either by the firewall or the server itself based on the rules you have setup. At first you might think, "ok well I'll just open the port it's translating to", but the port translation changes every time a packet is sent out. So the way to fix this is to disable outbound NAT on your firewall, or select a hybrid outbound NAT and specify a no translation policy for the internal network/subnet on which your server runs. Unfortunately I can't provide specific information on how you would go about configuring outbound NAT as each firewall software/hardware are different and the easiest way to obtain this information would be to reference the firewall manufacturer's documentation. I realize this thread is 3 years old so, if not the OP, hopefully it helps someone looking for an answer.

Page 1 of 1


Fast Reply

  

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2021 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942