Urban Terror Forums: 4.3.3 Brightness issue - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

4.3.3 Brightness issue Rate Topic: -----

Game brightness setting not reset on game exit

#1 User is offline   ge0rdie Icon

  • Account: ge0rdie
  • Country:
  • Joined: 28-December 10
  • Posts: 24

Posted 08 April 2018 - 08:47 AM

Hi All,

I have noticed that since 4.3.3 upgrade, when I exit the game, my brightness setting does not revert to what it was before running the game.

ie: I have my in-game brightness much higher than my desktop. When I exit the game, I have to go into settings and change it. Actually, what I do is swap from external monitor to built in monitor (laptop) then revert to external monitor, and I am back to normal.

Note, this did NOT happen in 4.3.2. On a slightly related note, on 4.3.2 I was unable to adjust brightness on my laptop screen, only on the external monitor.

OS: Ubuntu 17.10
Desktop: Gnome 3.26.2
Graphics: Nvidia GTX970M
Monitor: LG 34" ultra wide curved (they're shit, don't buy one)

Anyone else have this happen ?

--G

#2 User is offline   snowzz Icon

  •   verified donator   
  • Account: snowzz
  • Country:
  • Joined: 07-October 13
  • Posts: 111

Posted 09 April 2018 - 03:05 PM

I have the same thing now actually.

Every single time I open urt I have to adjust the brightness and sometimes I have to do it multiple times. Sometimes it's even coming back every 30 seconds or so (coming back I mean lowering the brightness again). I have a good system and no problem with other things and are not running many programs in the background.

#3 User is offline   Iye Icon

  •   head moderator   
    Co-Chief Community Moderator
  • Account: iye
  • Country:
  • Joined: 07-June 11
  • Posts: 960

Posted 09 April 2018 - 05:58 PM

Are you guys playing on fullscreen or borderless window mode?

Ive been playing on fullscreen with r_gamma 2.6 for ages, and recently (after the 4.3 update) added a 2nd monitor to my setup, but i dont have this issue. (not yet at least :)

I do recall originally playing on fullscreen because with windowed mode it would also affect the OS settings as described, which was just horrible to look at.
And since alt tabbing just takes a fraction of a second anyways, i didnt bother with it.
Sorry for my bad spelling - I am still asleep. :)

|=| Iye's UrT Addon |=| Firefox Personas |=| Maps |=|
http://www.mediafire...vk3a602hcfg.jpg

#4 User is offline   snowzz Icon

  •   verified donator   
  • Account: snowzz
  • Country:
  • Joined: 07-October 13
  • Posts: 111

Posted 10 April 2018 - 02:55 AM

Yeah I always play fullscreen.

#5 User is offline   ge0rdie Icon

  • Account: ge0rdie
  • Country:
  • Joined: 28-December 10
  • Posts: 24

Posted 10 April 2018 - 08:52 AM

Yep, full screen mode.


I also noticed that when I run the game, the desktop brightness goes up for a split second before the game splash screen displays.

#6 User is offline   ge0rdie Icon

  • Account: ge0rdie
  • Country:
  • Joined: 28-December 10
  • Posts: 24

Posted 20 April 2018 - 08:04 AM

FYI: just installed some OS updates and the problems seems to be fixed, wahoo !

#7 User is offline   Biddle Icon

  • Account: biddle
  • Main tag: fr.
  • Country:
  • Joined: 01-August 12
  • Posts: 1,044

Posted 20 April 2018 - 05:37 PM

Using a more modern version of the engine should fix all these issues.

#8 User is offline   snowzz Icon

  •   verified donator   
  • Account: snowzz
  • Country:
  • Joined: 07-October 13
  • Posts: 111

Posted 07 May 2018 - 11:03 AM

My issue turned out to be caused by flux, even though I disabled flux for in-game.

So all good!

#9 User is offline   cobalt60 Icon

  • Account: cobalt60
  • Joined: 15-January 11
  • Posts: 56

Posted 24 September 2018 - 05:42 AM

I know your issue is solved, but maybe someone will find the following info useful.

I always use a startup script to launch UrT. Brightness is one of the things my script addresses. Here is a simple example of a startup script that will raise your brightness when the game starts, and set it back to nowmal upon exiting:


#!/bin/bash
# Urban Terror startup script
# /usr/local/bin/urt43

# raises brightness before starting UrT
xrandr --output DVI-I-0 --gamma 1.8:1.8:1.8

# launches UrT
/home/YOURUSERNAME/UrbanTerror43/Quake3-UrT.x86_64

# set brightness back to normal upon exiting
xrandr --output DVI-I-0 --gamma 1.0:1.0:1.0



In the above example, replace "DVI-I-0" with whatever your monitor is; you can find this by running xrandr. A good place to put this startup script is in "/usr/local/bin"; that way, you can just launch a terminal and type in whatever you named your script, for example, "urt".

Theres lots more you can do with a custom script, right now I am modifying mine to enable full screen anti-aliasing for UrT.

This post has been edited by cobalt60: 24 September 2018 - 05:43 AM


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942