Urban Terror Forums: Assorted forum issues - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Assorted forum issues Rate Topic: -----

#1 User is offline   JRandomNoob Icon

  •   verified user   

Posted 04 October 2018 - 08:19 PM

  • I’m pretty sure I’ve already complained about this some years ago, but nothing came of it. Anyway the thing is, if my IP changes while I’m logged in, I can’t use the forum anymore — any forum page, whether it’s a thread, active topics display or whatever, redirects me to the https://www.urbanter...s/login/?logged landing page. This page always tells me that I’m logged in, which is sorta-kinda true because I can access everything else that’s not forum-related. (Back when QA still existed I could see and download all the files and whatnot). Logging out and in again fixes this — until next time.
    Even weirder is what happens when I spend some time away from the site (a few weeks or so) during which my IP can change repeatedly. In that case I can read the forum just fine, but all forum pages show me not logged in (the top bar doesn’t have my name, showing a “Login” link instead; posting buttons are gray; my name’s missing from the “Online:” bar at the bottom). On each page there’s a red box above the main content that says “LOGIN DISABLED: The authentication server is down”. First time this happened, I took it at face value and several days passed before I realized something might be off. This situation, too, doesn’t extend to pages outside the forum, and again, logging out and in again solves it.

  • When I messed up login some months ago I had to reset my password and discovered that the recovery password sent to your email has a trailing space. It’s very easy to copy the whole line.

  • Emoticons in older posts are now yelling at you that this is a RESTRICTED QA AREA and you better enter the correct password or get lost.

    Quote

    [23:56:58.455] × GET https://forums.urban...terror/cool.gif [HTTP/1.1 401 Unauthorized 2375ms]
    [23:56:58.456] × GET https://forums.urban...or/rolleyes.gif [HTTP/1.1 401 Unauthorized 2625ms]
    [23:56:58.457] × GET https://forums.urban...terror/ohmy.gif [HTTP/1.1 401 Unauthorized 2625ms]
    [23:56:58.458] × GET https://forums.urban...nterror/sad.gif [HTTP/1.1 401 Unauthorized 3016ms]
    (See e.g. https://www.urbanter...beta-7-pandora/ )

  • Also Unicode characters in older posts are broken now, see e.g. https://www.urbanter...post__p__316848 or the name of the author of https://www.urbanter...post__p__252745
    (I first noticed mojipuke in my sig)

  • The obfuscated FrozenSand link at the bottom of every page doesn’t work, you end up at https://www.urbanter...forums-request/ which says “Not Found: This content doesn't exist.” (According to a cursory check of the news page other such links are working fine.)

  • The “Forums search” heading in the left hand menu has been broken since forever (instead of a proper <h6> tag it starts with <h6">). (Also the order of normal and advanced search entries is imho backwards.)

  • Backslashes in posts need to be escaped now, either in order to put the filthy Windows peasants in their proper place or to cripple an anticipated onslaught of shruggies ¯\_(ツ)_/¯

dswp.de
Beginner’s Guide to Urban Terror (woefully out of date)
Daily Deadnade (Last updated September 9, 2016)



Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942