Urban Terror Forums: Can't seem to set fs_basepath in v43 - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Can't seem to set fs_basepath in v43 Rate Topic: -----

#1 User is offline   Keith27 Icon

  • Account: keith27
  • Joined: 22-October 18
  • Posts: 2

Posted 22 October 2018 - 03:29 AM

Hi all,

I'm trying to set up an UrT server on an Ubuntu machine with systemd, without screen. I installed urt to /usr/local/bin, which is where I usually put my binaries.

I made a user 'urt' but no home folder because I'm trying to keep /home free of such nonsense.

To cut to the chase, here's my service file:


[Unit]
Description=Urban Terror Server
After=network.target
Before=shutdown.target reboot.target halt.target

[Service]
ExecStart=/usr/local/bin/UrbanTerror43/Quake3-UrT-Ded.x86_64 +set fs_game q3ut4 +set fs_basepath /usr/local/bin/UrbanTerror43 +set fs_homepath /usr/local/bin/UrbanTerror43/ +set dedicated 2 +set net_port 27960 +set com_hunkmegs 128 +exec server.cfg
User=urt
Group=urt
Type=forking
;Restart=on-failure

[Install]
WantedBy=multi-user.target



But when I run it, I get this error:
Sys_Error: Unable to create directory "/home/urt/.q3a", error is No such file or directory(2)


Now, according to this five-year-old thread, setting fs_homepath should force the .q3a folder to be built there, in /usr/local/bin/UrbanTerror43/. That's where I want it.

Everything runs fine if I run the service with User=root, creating the .q3a directory in /root/... but I don't want to run it as root if I don't have to. I'll create the stupid /home/urt folder before I do that.

Most likely, the name of the fs_homepath variable has changed in v43 and I'm just copying old, no-longer-relevant instructions. Is there a way to set the .q3a location in v43?


#3 User is offline   Keith27 Icon

  • Account: keith27
  • Joined: 22-October 18
  • Posts: 2

Posted 24 October 2018 - 05:56 PM

Oh, so there's a use_defaultHomePath cvar? Why didn't you say so? :rolleyes:

I just changed the service file to include '+set use_defaultHomePath 0', like so:

ExecStart=/usr/local/bin/UrbanTerror43/Quake3-UrT-Ded.x86_64 +set use_defaultHomePath 0 +set fs_game q3ut4 +set fs_basepath /usr/local/bin/UrbanTerror43 +set fs_homepath /usr/local/bin/UrbanTerror43/ +set dedicated 2 +set net_port 27960 +set com_hunkmegs 128 +exec server.cfg


And that solved that. Thanks!

Side note to people coming from google:
If you're using systemd without screen, you probably also have to remove Type=forking from the service file to prevent a systemd startup timeout. That worked for me (I had just copied the service file from someone who was using screen). (source: Unix/Linux Stack Exchange: Systemd timeout because it doesn't detect daemon forking)

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942