Urban Terror Forums: Server No Longer In In-Game List - Urban Terror Forums

Jump to content

 Login | Register 
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Server No Longer In In-Game List Rate Topic: -----

#1 User is offline   Dirtycamacho Icon

  • Account: dirtycamacho
  • Country:
  • Joined: 19-March 20
  • Posts: 2

Posted 14 August 2020 - 12:56 AM

Hey everybody,

Before I begin I apologize as I know home setups are not supported, but I'd like to believe my setup is far from your typical home setup.

I host a server in my lab and my friends and I have been playing on it since the COVID-19 outbreak began. I was in Miami at that time. The server worked great and was listed in the in-game server list. I recently moved to Las Vegas and since then the server no longer appears in the in-game list or on the urbanterror.info/servers site. I've tested myself and with a friend in a different state that direct connect works just fine, but I can't be found in the server list. The setups (in my eyes) are identical except geographically speaking. Setup below.

  • DOCSIS3.1 modem (500Mbps/50Mbps, configured in bridge mode, statically assigned IP, don't ask how I smooth-talked my way into that)
  • pfSense firewall (NAT port forward of UDP 27900, 27950-27952, 27960 redirected to internal IP of server with associated firewall rule allowing incoming connections)
  • XCP-NG Cluster host (not that that should matter..)
  • VM - Ubuntu Server 20.04 with UFW enabled and aforementioned ports allowed in, default allow all out

Server Exec Command:
Quake3-UrT-Ded.x86_64 +set fs_game q3ut4 +set fs_basepath /XXX/urbanterror +set fs_homepath /XXX/urbanterror +set dedicated 2 +set net_port 27960 +exec server.cfg
**fs_basepath and fs_homepath are set to the same value**

Outside of the geographical move, the only thing of note is that I ended up having to reinstall pfSense on the firewall after getting here because of a bad SSD, but I restored the backup I took from before the move so the configuration should not have changed.

As I said, this worked great before and we'd love to start playing again, but at this point I can't ask some of my technically-challenged friends to direct connect by IP. Any and all advice is greatly appreciated. Happy to provide any additional information. Thanks!

After hitting my head against the wall on this for the last 2 weeks I searched the master servers for my public IP and found that there were multiple entries. Looked at my firewall and for some reason the Outbound NAT mode reset itself to a default. I've set it back to Hybrid mode with a static mapping for the host. Master servers now have my IP listed with the correct UDP port (and only that port (27960)). The server is now in the in-game list. Topic can be closed.

This post has been edited by Dirtycamacho: 29 August 2020 - 11:34 PM

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users


Copyright © 1999-2021 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942