Urban Terror Forums: Unplayable on M1 MacBook Pro - Urban Terror Forums

Jump to content

 Login | Register 
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Unplayable on M1 MacBook Pro Rate Topic: -----

#1 User is offline   wutangspawncamper Icon

Posted 09 August 2021 - 10:58 PM

I have a new MacBook Pro with the M1 processor.

I've installed the game from scratch and I'm only getting 10-20 fps. I've tried turning all the video settings "down" but it doesn't help.

Is this the end of the line for UrT on Mac?

#2 User is offline   Handyman001 Icon

Posted 25 October 2021 - 01:29 AM

I see that it has been 2 months since your post. I'm experiencing the same issue on the M1 MacBook Air. This seems to be an Urban Terror issue, since ioquake3 has M1 compatibility now (https://ioquake3.org...quake3-support/), and Quake 3 by itself does not have any performance issues.

There must be something in Urban Terror's configuration that is causing poor performance on the M1. I think diffing the q3config.cfg between a vanilla Quake 3 and Urban Terror should point to something? Just a thought, I have not tried this myself.

#3 User is offline   Handyman001 Icon

Posted 15 March 2022 - 12:16 AM

It sounds like it's the end of the road for UrT for Mac. It has something to do with UrT, and not Quake 3 or OpenGL, since those things still perform well. And it's certainly not a hardware performance issue. Hopefully there's enough interest in this issue that someone finds a workaround.

#5 User is offline   swedishchef Icon

Posted 02 April 2022 - 06:30 PM

View PostMr.Yeah, on 15 March 2022 - 03:23 PM, said:

Someone did! Solitary built an updated version of https://github.com/ftwgl/Quake3e that reportedly works fine on M1,
you can find it on discord at https://discord.gg/ez4v5bv, It's in the pinned messages of #urt-support

Works just fine on my M1 powered MacBook Air. Only issue I'm having is that the mouse doesn't want to pan a full 360º. It goes just so far to the right and stops.

This post has been edited by swedishchef: 03 April 2022 - 08:22 PM

#6 User is offline   Omavel Icon

  • Account: omavel
  • Joined: 21-April 22
  • Posts: 3

Posted 21 April 2022 - 09:50 PM

Latest UT doesn't support native M1's dpi/screen resolutions - am I right?
I set 1366×768 but actually it is about 2732×1592 and a bit soapy.

#7 User is offline   Handyman001 Icon

Posted 11 July 2022 - 03:38 PM

I followed the pinned message on discord and works great. There's also instructions on fixing the mouse issue. They're very active, so chat in there and you're sure to receive help

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users


Copyright © 1999-2022 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942