Urban Terror Forums: Need help with first install on Debian - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Need help with first install on Debian Rate Topic: -----

#1 User is offline   Keithostertag Icon

Posted 09 March 2018 - 12:33 AM

I've never played games before, and thought I'd try it out. I am using Debian with a tiling window manager (not a DE).

I downloaded the updater and retrieved a bunch of files. I made some mistakes- I at first thought I needed to run a local server and tried to follow the directions for that. I created a user 'urt' to run the game from.

So, I just ran the updater again, and it tells me I'm updated and do I want to play? I say "y" and it gives me this:



Your game is up to date!
Would you like to play now? [y/n]: y
ioQ3 1.35 urt 4.3.3 linux-x86_64 Feb 28 2018
----- FS_Startup -----
Current search path:
/home/urt/.q3a/q3ut4
/home/urt/.q3a/q3ut4/download
/home/urt/urbanterror43/q3ut4/zUrT43_qvm.pk3 (4 files)
/home/urt/urbanterror43/q3ut4/zUrT43_021.pk3 (85 files)
/home/urt/urbanterror43/q3ut4/zUrT43_020.pk3 (295 files)
/home/urt/urbanterror43/q3ut4/zUrT43_019.pk3 (342 files)
/home/urt/urbanterror43/q3ut4/zUrT43_018.pk3 (801 files)
/home/urt/urbanterror43/q3ut4/zUrT43_017.pk3 (734 files)
/home/urt/urbanterror43/q3ut4/zUrT43_016.pk3 (487 files)
/home/urt/urbanterror43/q3ut4/zUrT43_015.pk3 (60 files)
/home/urt/urbanterror43/q3ut4/zUrT43_014.pk3 (510 files)
/home/urt/urbanterror43/q3ut4/zUrT43_013.pk3 (353 files)
/home/urt/urbanterror43/q3ut4/zUrT43_012.pk3 (271 files)
/home/urt/urbanterror43/q3ut4/zUrT43_011.pk3 (478 files)
/home/urt/urbanterror43/q3ut4/zUrT43_010.pk3 (1423 files)
/home/urt/urbanterror43/q3ut4/zUrT43_009.pk3 (476 files)
/home/urt/urbanterror43/q3ut4/zUrT43_008.pk3 (962 files)
/home/urt/urbanterror43/q3ut4/zUrT43_007.pk3 (368 files)
/home/urt/urbanterror43/q3ut4/zUrT43_006.pk3 (553 files)
/home/urt/urbanterror43/q3ut4/zUrT43_005.pk3 (898 files)
/home/urt/urbanterror43/q3ut4/zUrT43_004.pk3 (558 files)
/home/urt/urbanterror43/q3ut4/zUrT43_003.pk3 (53 files)
/home/urt/urbanterror43/q3ut4/zUrT43_002.pk3 (100 files)
/home/urt/urbanterror43/q3ut4/zUrT43_001.pk3 (759 files)
/home/urt/urbanterror43/q3ut4/ut4_jumpents.pk3 (8 files)
/home/urt/urbanterror43/q3ut4
/home/urt/urbanterror43/q3ut4/download

----------------------
10578 files in pk3 files
execing default.cfg
"MINUS" isn't a valid key
"PLUS" isn't a valid key
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
No protocol specified
No protocol specified
No protocol specified
Received signal 11, exiting...
----- CL_Shutdown -----
RE_Shutdown( 1 )
./UrTUpdater_Ded.sh: line 315:  7481 Segmentation fault      "${CWD}/${engineDir[$i]}/${engineLaunchString[$i]}"





Looks like it thinks I'm on a Windows PC, saying it's looking for autoexec.cfg? Weird, but I am completely unfamiliar with running games so I don't know what to think. Can someone help me out here?


urt@ada:~/urbanterror43$ uname -a
Linux ada 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64 GNU/Linux



I would much prefer to install it as a deb file, but can't find one... I can't use the ones made for Ubuntu (it seems), and the link on sourceforge.net seems to only be for the i386 version, not the x86_64 version.

This post has been edited by Keithostertag: 09 March 2018 - 12:49 AM


#2 User is offline   Iye Icon

  •   head moderator   
    Co-Chief Community Moderator
  • Account: iye
  • Country:
  • Joined: 07-June 11
  • Posts: 960

Posted 09 March 2018 - 08:05 PM

the autoexec.cfg is a q3 script/config file loaded/executed within the game if you start it. You can safely ignore this error.

your game actually crashes during SDL_Init, so its some sort of issue with that. However, im entirely unfamilier with these things. Guessing from about 5 mins of googling and combining that with something i recall reading on discord about 2 weeks ago, it might be that its a permission issue. Or your SDL lib isnt installed correctly. or im entirely wrong. Again, im guessing here :)
Sorry for my bad spelling - I am still asleep. :)

|=| Iye's UrT Addon |=| Firefox Personas |=| Maps |=|
http://www.mediafire...vk3a602hcfg.jpg

#3 User is offline   Keithostertag Icon

Posted 10 March 2018 - 07:03 PM

Thank you for taking the time to get back with me about this.

Using a different machine (but with very similar setup) I was able to download the files and run the updater, and subsequently start the game. So, yea, I'll reload the other machine, thanks for suggesting the possible permissions problem.

Keith

#4 User is offline   cobalt60 Icon

  • Account: cobalt60
  • Joined: 15-January 11
  • Posts: 56

Posted 24 September 2018 - 05:50 AM

I am a Debian user myself, and although a .deb file would be nice, I don't think any such thing is available for Debian, and using an Ubuntu .deb is not a good idea. . The only packages you really need are "curl" (don't quote me on exact package name) and maybe one other, launching from a terminal clearly tells you the needed packages if you don't have them.

Here's a command showing the basic way to launch UrT from a terminal

/home/YOUR_USER_NAME/UrbanTerror43/Quake3-UrT.x86_64


The above assumes your UrT folder is located right in your home directory.

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

Advertisement


Copyright © 1999-2019 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942