Urban Terror Forums: killspree - Viewing Profile - Urban Terror Forums

Jump to content

 Login | Register 
Advertisement

killspree's Profile

killspree's Photo
Group:
Members
Active Posts:
307 (0.1 per day)
Most Active In:
Urban Terror 5 Mapping (57 posts)
Joined:
21-November 12
Profile Views:
12,553
Last Active:
User is offline Nov 29 2020 09:50 PM
Currently:
Offline

My Information

Age:
35 years old
Gender:
Not Telling Not Telling
Page Width:
Proportional

Contact Information

E-mail:
Private

Topics I've Started

  1. scripts advice

    21 November 2020 - 09:11 AM

    Hi folks,

    I'm trying to create some scripts and have looked at some shader files.
    But, when I try to apply a decal for a crack in the floor I get ugly shadows on the entire brush.

    I used this shader:


    textures/myfolder/mytexture
    {
    // surfaceparm trans
    polygonOffset
    nomipmaps
    nopicmip

    {
    map textures/myfolder/mytexture.tga
    blendfunc filter
    }
    }

    I also tried to apply this shader:



    textures/myfolder/mytexture

    {
    surfaceparm trans
    polygonOffset
    nomipmaps
    nopicmip

    {
    map textures/myfolder/mytexture.jpg
    blendfunc filter
    }

    // {
    // map textures/myfolder/mytexture.tga
    // alphaFunc GE128
    // depthwrite
    // }
    // {
    // map $lightmap
    // rgbGen identity
    // blendFunc GL_DST_COLOR GL_ZERO
    // depthFunc equal
    // }

    }

    I have tried to replace the .jpg format on the second shader and tried to remove the double \ but this shader seems to only show the infamous texture that is shown when a texture is missing.

    Lastly, I have put this shader on a manhole cover:


    textures/myfolder/mytexture
    {
    qer_editorimage textures/myfolder/mytexture.tga
    surfaceparm metalsteps
    surfaceparm trans
    surfaceparm alphashadow
    surfaceparm playerclip
    surfaceparm nonsolid
    surfaceparm nomarks
    cull none
    nopicmip

    {
    map textures/myfolder/mytexture.tga
    blendFunc GL_ONE GL_ZERO
    alphaFunc GE128
    depthWrite
    rgbGen identity
    }
    {
    map $lightmap
    rgbGen identity
    blendFunc GL_DST_COLOR GL_ZERO
    depthFunc equal
    }
    }

    I have placed it just above the floor and it does work like a proper alpha masked image, but from a distance, you start to see a white line around the image.
    I have tried to apply the first shader to the manhole cover and it does work but you can again see ugly shadow lines around them and obviously, you can see the stone floor through the steel manhole cover.

    Am I better of just pasting the decals I want to use on floors on the textures in gimp or photoshop and only use decals on walls?


Friends

Comments

killspree has no profile comments yet. Why not say hello?

Sponsored link
https://www.frozensand.com/


Copyright © 1999-2021 Frozensand Games Limited  |  All rights reserved  |  Urban Terror™ and FrozenSand™ are trademarks of Frozensand Games Limited

Frozensand Games is a Limited company registered in England and Wales. Company Reg No: 10343942